fc2ブログ

Windows11にログイン(サインイン)したら画面が真っ黒になったときの備忘録

Windows11のアプデ後の再起動からサインインしたら
白い四角の枠とお待ちくださいのメッセージが長らく続いた後
真っ暗な画面でマウスポインタのみ出てくる画面になった。

結論からいうと、セーフモードで起動(Shiftキーを押しながら、再起動ボタン)
 →グラボの最新ドライバをクリーンインストール
 →再起動
で治りました。

クリックしてもポーンというシステム音。
Ctrl + Alt + Delは機能するのだけどタスクマネージャは起動してるのかしてないのか選んでも真っ暗なまま。
Ctrl + Alt + Delを押すと右下に電源メニューは出るのでサインアウトしてみる。
このまま再起動しても同じ状況の繰り返し。
原因はその時々で違うだろうけど、グラボ起因の場合が多い様子。
サインイン画面から右下の電源メニューの再起動をShiftを押しながらクリック。
セーフモードで再起動してくるのでトラブルシューティングから詳細オプションを選択。
スタートアップ設定を選んでから再起動をクリック。
5のネットワーク有りのセーフモード起動を選択。
セーフモードで起動できたらグラボの最新ドライバをダウンロードしてきてクリーンインストール。
再起動で通常ログインできればOK。

アプデの問題ならセーフモードのブートメニューからアプデを取り消すこともできるようです。

追記:
FreeSync対応可能モニタを繋いでる場合に生じる?
グラフィックドライバのアップデートがない場合は上記現象はでないように思えます。
そのうち修正されるのかな…?
追記:2022.05.13
上記対応では改善されないケースがあり確認したところSound Blasterが妨げてた様子。
デバイスを一旦無効にするとサインインできました。
参考
https://forest.watch.impress.co.jp/docs/news/1408332.html
追記:20022.06.20
セーフモード起動する手順するときのスタートアップ設定メニューの
7) ドライバー署名の強制を無効にする
8) 起動時マルウェア対策をを無効にする
を試してみる。

追記:20022.09.06
上記を試しても同じ状況から抜け出せなくて困っていたのですが、
Norton Securityをアンインストールするとサインインできました。


AVerMedia Live Gamer 4K GC573 Windows Update後に認識されない問題

Windows Update 21H1 を行ったら AVerMedia Live Gamer 4K GC573 が
キャプチャーデバイスが見つかりません
とエラーが表示されるようになった。
デバイスマネージャではコード22だが有効化しても失敗する。
遠回りしてしまったけど、単にデバイスマネージャから一旦アンインストールして
公式から最新ドライバだけダウンロードしてきて再インストールすると認識された。

ICカードリーダライタ ACR39-NTTCom がマイナンバーカードを読み取らない

ICカードリーダライタ ACR39-NTTCom が使えなくなって困った件の備忘録

確定申告が近付いて税務署からメールがきたのだけど
e-taxのHPのメール読むだけでマイナンバーカードがいる。
久々にICカードリーダ(ACR39-NTTCom)を取り付けてマイナンバーカードを
読み取ろうとしたらエラーメッセージが出た。
去年は動いてたのに。

やったことは
e-taxのHPよりJPKI最新版のインストール(上書き) (*a)
ACR39ドライバの修復インストール
https://www.ntt.com/business/services/application/authentication/jpki/download6.html
ACR39ドライババージョン確認ツールダウンロード(同サイトより)
ここまでやってカードが読み取れず。

ドライババージョン確認ツールを実行すると、
The Smart Card Resource Manager is not running
と表示される。

デバイスマネージャで
スマートカード読み取り装置-ACR39U ICC Reader
が表示され、正常に動作していることを確認。

スタートメニューからWindowsの管理-サービスを実行
サービスの一覧に
Smart Card
が存在せず
Smart Card Device Enumeration Service (手動)
Smart Card Device Removal Policy (手動)
が存在することを確認。

Smart Cardサービスが存在しないことがおかしいので色々やってみたが、
Sony製カードリーダのソフトウェアを入れてみることにした。 (*b)
NFCポートソフトウェア(旧FeliCaポートソフトウェア)
https://www.sony.co.jp/Products/felica/consumer/download/felicaportsoftware.html
PC/SC アクティベーター for Type B
https://www.sony.co.jp/Products/felica/consumer/download/pcscactivator.html

ここでSmart Cardのサービスが実行されていることを確認。
(ファイルが存在すれば単にサービスの登録でいけると思う。)

しかし、ACR39ドライババージョン確認ツールを実行すると、
The Smart Card Resource Manager is not running
と表示される。

一度ICカードリーダーを”取り外して”から
ACR39ドライバの削除を実行、再度インストール。 (*c)

その後、ICカードリーダーをUSBに差し込む。

サービスの一覧から
Smart Card Device Enumeration Service
をダブルクリックして自動起動に変更、サービスの開始をクリック。 (*d)
これでドライババージョン確認ツールを実行すると、
スマートカード一覧が表示されるようになった

再度、e-taxページでマイナンバーカードを読み取ると無事実行された。

同様の症状に陥ったら恐らく、(*a)~(*d)の箇所を実行すればよいかと思う。
もっとスマートなやり方があるかもしれないが、とりあえず。



LS420D LinkStation HDD 2台交換

LS420DのHDDを2台一度に8TBHDDに換装した時のメモ。
!注意
この記事は2台のHDDを全部一度に交換する方法を書いてますが、
通常は1台ずつ交換できると思うので、可能な場合はそちらをおすすめします。
1台ずつ交換する方法は管理画面からやれると思います。
また、下記方法は公式ではありませんので自己責任でお願いします。


[経緯]
1台のHDDが破損していたのでついでに8TBのHDDにしようとあれこれしていたら
Web管理画面のTOPがグレー一色で操作できなくなってしまった。
やむなく全てのHDDを換装した状態でファームウェアを転送することにした。

[実施内容]
概ね以前に記事にした
Buffalo NAS LinkStation LS-VL (LS-2.0TL) HDD 交換
と同じ流れになる。

ちょっとやっかいなのがLS420DはDHCPサーバがネットワークにない場合
>IPアドレス:169.254.xxx.xxx (xxxは本製品起動時に任意の数値が割り当てられます。)
>ネットマスク:255.255.0.0

となること。

方法は色々考えられるが、今回はルータをかませることにする。

ダウンロードしておくもの。
・最新ファームウェアのダウンロード。
https://www.buffalo.jp/product/detail/software/ls420d0402.html

・TFTP Boot Recoveryのダウンロード。
以前TFTP Boot Recoveryを配布していたサイトからダウンロードできなくなっているようなので
「TFTP Boot Recovery 1.53.rar」などで検索するとまだダウンロードできる場所がある様子。


NAS Navigator2のダウンロード。
https://www.buffalo.jp/product/detail/software/ls420d0402.html


・ファイルの準備。
ファームウェア(ls400-vxxx.exe)を解凍して
initrd.imgをコピーしてからinitrd.zipにリネーム。オリジナルはとっておく。
initrd.zipを同じフォルダに解凍。
パスワードは「LinkStation HDD交換」で検索するとすぐ見つかります。

uImage.imgをコピーしてからuImage.zipにリネーム。オリジナルはとっておく。
uImage.zipの中身のuImage.buffaloを同じフォルダに解凍。
(もしuImage-lsp.5.x.buffaloみたいな名前だったらリネームしてuImage.buffaloとする。)

同じフォルダにあるLSUpdater.iniを編集して以下のように値を変更。

[Flags]
VersionCheck = 0
NoFormatting = 0

任意の日本語を含まないフォルダ(C:\buff など)を作って、そこに上記ファイル群と
TFTP Boot Recoveryを解凍して入れる。
要は全部のファイル一緒に入れてOK。
ただし、
uImage.buffalo と initrd.buffalo はファームウェアから取り出したものを使うこと。
TFTP Boot Recoveryに同梱されているものは使わない。


・ネットワークの準備。
インターネットに繋がなくてよいのでルータを準備し
LS420Dの電源は切った状態で、
[ルータ]
  ├[LS420D]
  └[PC]

の状態にする。
ルータのIPを192.168.11.2とし、
DHCPの開始IPは192.168.11.3からとする。
PCのIPアドレス(IPv4)を固定IPの192.168.11.1とする。
この状態にできたらTFTP Boot.exeを起動しておく。
コンソールが出て待ち受け状態になるはず。
PCのファイアウォール関連は切っておくこと。

・HDDの換装。
LS420Dに新しいHDD2台を装着する(未フォーマットでよい)

・LS420Dの電源を入れる。
電源を入れると、ランプが高速で白点滅してのちに赤が点滅しはじめるはず。
ここでファンクションキー(前面のスイッチ)を押すとまた高速で白点滅がはじまる。
これで192.168.11.1へファームウェアを取得に行くはずなので
TFTP Boot Recoveryのコンソールに応答があるはず。
しばらく待っていると、白点滅から白点灯に変わるはず。

ここでNAS Navigator2で検索するとemモードで立ち上がってるはず。
この状態でファームウェアのアップデートを実行(LSUpdater.exe)。
パーティションを切ってフォーマットするか聞かれるので実行する。
アップデートが終われば完了なので本来のネットワークに戻し、
NASの各設定をWeb管理画面より行う。

以上になります。

QNAP 231+ が勝手にシャットダウン

QNAP 231+ の電源が勝手に落ちる現象がちょいちょい発生するようになって調査。
状況を見ると電源が突然バチンと落ちるのではなく、
ちゃんとシャットダウンの手順を踏んでいるようだけど
タイミングがわからない。

通知にもなにも表示されていないけどどうも温度の問題じゃないかと当たりを付ける。
システム温度はさほどでもないけどHDDの温度がアツアツになってた。
どうも60度に達すると勝手にシャットダウンを行うような情報が。

コントロールパネルからハードウェア->スマートファンを開く。
試しに手動で設定して高速にしてみるとちゃんとうなりをあげてファンが回るので
ファンは生きている様子。
手動設定で固定にしてもよいのだけど、スマートファンは有効のまま
温度設定を定義するを選択してみる。
ほとんど回ってなかったファンがほどほど回るようになり、HDDの温度も
かなり下がりました。(40度くらい)

これでしばらく様子見。
検索フォーム
RSSリンクの表示
リンク
ブロとも申請フォーム

この人とブロともになる

QRコード
QR